Formularrahmen

Hallo,

ich möchte gerne einen neuen Formularrahmen erstellen, mit CHF anstatt EUR.

Konnta das ganze auch als neuen Formularrahmen speichern.
Habe im editor „EUR“ durch „CHF“ ersetzt.

wenn ich eine Datei ausdrucke erscheint jedoch trotzdem „Einzelpreis CHF EUR“.

wie bekomme ich das EUR weg?

dankeschön schonmals :slight_smile:

Hallo,

ich möchte gerne einen neuen Formularrahmen erstellen, mit CHF anstatt EUR.

so einfach geht das nicht, da das Programm intern weiter mit EUR rechnet. Daher musst du immer auch den Umrechnungskurs im Auftrag hinterlegen, da das Finanzamt ansonsten immer zu deinen Ungunsten eine Währung annimmt. Ein Formularrahmen für die WaWi pro/premium, der das korrekt unterstützt, gibt es unter https://lexshop.org/Formulare/warenwirtschaft-pro/Fremdwaehrung-mit-Fremdsprache-fuer-Auftrag-und-Mahnung--81.html?refID=41119. Oder ist der Firmensitz in der Schweiz, sodass gar kein EUR mehr notwendig ist?

Konnta das ganze auch als neuen Formularrahmen speichern.
Habe im editor „EUR“ durch „CHF“ ersetzt.

wenn ich eine Datei ausdrucke erscheint jedoch trotzdem „Einzelpreis CHF EUR“.

wie bekomme ich das EUR weg?

an vielen Stellen wird das Zahlenformat so definiert, dass dort automatisch die Währung dranhängt. Daher würde ich - bei einer rein schweizer Lösung - die Währung hinter der Ziffern im Layout deaktivieren und nur in den Spaltenköpfen entfernen.

Hallo, vielen Dank für die Antwort.

ich bin nur ausführende Gewalt - von daher weiß ich nicht, wie das intern geklärt werden soll.

Ich habe nur den Auftrag bekommen, dies umzuändern.


Die Währungen sind auch ausgeschaltet aber in der Kopfzeile der Tabeölle steht eben immer noch EUR obwohl ich dies doch im quelltext geändert habe?

Hallo,

wenn du es in der Tabellen-Kopfzeile geändert hast, aber sich nichts tut, dann war die Änderung vermutlich an der falschen Stelle. Beachte bitte, dass es für Netto, Brutto und Lieferschein verschiedene Bereiche gibt. Du musst also im richtigen „BaueTabelle…“ arbeiten.

Hallo Udo Netzel,

nochmals danke für die Rückmeldung.

Also wir haben mehrere Firmen in Lexware angelegt, unter anderem auch unsere Schweizer Tochterfirma, diese läuft komplett auf Franken. Daher dürfte es dort ja keine Probleme geben.

Allerdings verwirrt mich deine Antwort doch etwas - was genau meinst du mit „Baue Tabelle…“ ?

Hallo,

OK, dann ist schon mal das Rechtliche klar.

Allerdings verwirrt mich deine Antwort doch etwas - was genau meinst du mit „Baue Tabelle…“ ?

Äh, wo hast du denn in den Tabellenkopfzeilen das „EUR“ rausgenommen??? Das findest du im Quelltext unter den Funktionen „Function BaueTabelleNetto()“ und „Function BaueTabelleBrutto()“ und „Function BaueTabelleLieferschein()“.

SetCellText(C_H_Spalte_5, sTextSpalte_5 + strWaehrung) ' default "Einzelpreis"

und

SetCellText(C_H_Spalte_7, sTextSpalte_7 + strWaehrung) ' default "Gesamtpreis"

Hallo Udo Netzel,

vielen Dank - jetzt funktioniert es :slight_smile:

habe jedoch noch ein Problem. Anstatt Bearbeiter steht nun „processed by“ oben im Infoblock und UST wurde auch zu TVA.

Wie kann ich denn das ändern? finde leider nichts :frowning:

danke

Hallo,

dann hast du die Änderungen auf Basis des Formulars „layp_eng.lsf“ anstatt „lay_pro.lsf“ vorgenommen. Es müssten doch auch alle anderen Dinge (außer Tabellen-Inhalte) in Englisch erscheinen.

hab’s jetzt gefunden :slight_smile:

Alles klappt - vielen Dank :slight_smile: