Abschied von Lexware nach Umstieg von XP auf Win 7 ?

Hallo, Allerseits!

Ich hoffe, dass mein Einstiegsbeitrag nicht auch gleichzeitig mein Abschiedsbeitrag ist…

Es ist nicht übertrieben: nachdem ich Anfang des Jahres den Umstieg von XP auf Win7 nicht mehr aufhalten konnte, musste faktura+auftrag plus in den Versionen „hochgezogen“ werden – aber: ich schaffe jetzt seit mehr als einem 3/4 Jahr den Umstieg nicht und habe nur für F+A immer noch einen separaten XP-Rechner im Einsatz.

Ausgangslage ist faktura+auftrag plus 2007, angedachtes Zwischenziel war mit der Zwischenversion 2009 erst einmal auf 2010.

Gefühlte 20-30 (und wahrscheinlich auch tatsächliche) Installationsversuche schlugen fehl: die Daten sind immer da, aber die Formulare definitiv nicht! Word wird zwar geöffnet, aber die dot-Datei nicht (nichts, noch nicht einmal ein weißes „Blatt“ in Word).

Auf Win7 sämtliche vorhandenen Versionen (von 2006, 2007 über 2009 auf 2010) mit den von Lexware vorgeschlagenen Pfaden durchgespielt, wie auch mit den Pfaden auf dem ursprünglichen XP-Rechner (c:\lexware\ bzw. c:\lexware\daten) – Ergebnis immer das Gleiche: die Daten sind da, die Formulare öffnen sich nicht.

Auf einem 2. XP-Rechner (ich wollte mir ja die funktionierende Ausfertigung nicht auch noch zerschießen) die Versionen auf 2010 „hochgezogen“ (alles bei Stand 2007 eingespielt), Daten und Formulare gesichert, Datensicherungen auf dem Win7-Rechner eingespielt: nichts, wieder sind die Daten da, aber die Formulare öffnen nur Word, nicht aber die entsprechende dot-Datei.

Auch bei der aus der „Ur-Alt“-Installation stammenden Datei „Auftrag nach Word“, bzw. &FP\Faktura1_netto.dot tut sich nichts.

Es ist auch egal, ob ich Daten und Formulare nach der Installation der 2007er Version einspiele, oder erst später, das Ergebnis ist immer das gleiche.

Beim letzten Versuch wollte ich dann Cleverness mit einbringen, da ich gemerkt habe, dass F+A die dot-Dateien aus der Installationsroutine öffnet: also wieder komplette Neu-Installation und NUR die Daten eingespielt und die Formulare „manuell“ in den entsprechenden Datenpfad eingespielt; in der Formular-Verwaltung die „mitgelieferte“ Datei „Faktura1_netto.dot“ kopiert und bei Vorlagendatei mit &FP\meineRechnung.dot abgeändert.

Ha, Word geht auf, die dot-Datei geht auf, aber: „Fehler beim Kompilieren: Projekt oder Bibliothek nicht gefunden“, dann ist in dem Makro was mit „Sub ReplaceTextFromXML()“, sowie „ifcXMLNode As IXMLDOMElement“ farblich markiert. :imp:

Ergo: es geht bei mir einfach nicht.

Im Netz kann man auch vergeblich suchen, hierzu findet man einfach nichts. Bin ich denn der Einzige, der Lexware schon auf Windows 7 umstellen wollte? :laughing:

Hat jemand eine Idee?

Gruß

Achim D-Punkt

Hallo Achim,

na na… :slight_smile:

DIE Formular oder tatsächlich „nur“ die .dot Vorlage? Also kannst Du über die Standardformular Dir Aufträge in der Druckvorschau anzeigen lassen?

Der Ablauf wäre eigentlich so: http://lex-blog.de/2015/04/08/wechsel-altversion-neuversion-lexware/

Ganz sicher nicht. :slight_smile: Es könnte mit dem Punkt der doch recht alten Ausgangsversion zu tun haben und ggf. in einem Zwischenprozess ist irgendetwas nicht „regelkonform“ gelaufen.

Solange das Standardformular nicht aus der Datensicherung kommt: JA !

Kommt es aus der Datensicherung, dann nicht - dann öffnet sich nur Word und sonst tut sich nichts mehr - blaues Word, noch nicht mal ein weißes „Blatt“…

Was mich auch stutzig macht: irgendwo bei X-ten Neu-Installation bin ich dazu übergangen, penibel darauf zu achten, dass ich den Installationspfad von Anfang an exakt wie auf dem XP-Rechner benenne (C:\Lexware und C:\Lexware\Daten), ich weiß ja eigentlich auch nicht, was Lexware bei der Rücksicherung mit der ZIP-Datei veranstaltet, bzw. wo sie hingespielt wird.

Die Pfadangabe bei der Installation scheint Lexware aber auch nicht großartig zu interessieren: die Formulare liegen nämlich jetzt aktuell auf C:\ProgramData\Lexware\faktura + auftrag\Formular - das könnte ja vielleicht schon mal was mit dem Kompilierungsfehler zu tun haben, oder?

Ganz ehrlich erkenne ich nichts, was ich anders hätte machen sollen: 2006 + 2007 waren da, zu 2010 sollte es zunächst hin, die Zwischenversion 2009 kam von Lexware höchstpersönlich - da 2006 und 2007 auf dem Win7-Rechner mal laufen, meist aber gar nicht, habe ich ja Lexware auf dem 2. XP-Rechner installiert (den eigentlichen, funktionierenden XP-Rechner wollte ich mir jetzt nicht auch noch „abschießen“) und dort die Versionen hochgezogen: 2006, 2007 → jetzt die Datensicherung eingespielt (weil der eigentliche XP-PC ja Stand 2007 hat), danach die Zwischenversion 2009 und zuletzt die 2010er. Jetzt gesichert.

Die Versionen auf dem Win 7-Rechner erst ab 2009 installiert und beim Stand 2010 die Rücksicherung eingespielt.

Also, knappe Zusammenfassung der jetzigen IST-Situation:

  1. aus der Datensicherung heraus funktioniert gar nichts, außer dass sich Word öffnet (auch mit den Standardformularen);

  2. keine Rücksicherung der Formulare, sondern manuelles Kopieren der eigenen Formulare in den o. g. Datenpfad;

Standardformular „Faktura1_netto.dot“ funktioniert (wenn es nicht aus der Datensicherung kommt), und in Word wird alles korrekt umgesetzt;

Wenn ich die „Faktura1_netto.dot“ in der Formularverwaltung kopiere und die Vorlagendatei von „&FP\Faktura1_netto.dot“ in „&FP\MeineRechnung.dot“ umbenenne, passiert auch was: es kommt zwar zunächst in Visual Basic der Hinweis „Fehler beim Kompilieren: Projekt oder Bibliothek nicht gefunden“, schließe ich aber Visual Basic, ist das Formular zumindest schon mal da, allerdings werden die Variablen nicht gesetzt - ansonsten ist das jetzt aber zumindest schon mal wieder mein Formular…

Aber der Kompilierungsfehler im Visual Basic macht mich schon stutzig

beim Hinweis werden im Makro „Sub ReplaceTextFromXML()“ und etwas tiefer „Dim ifcXMLNode As IXMLDOMElement“ farblich hervorgehoben.

im Makro ist auch die Zeile „bLoad = ifcXML.Load(strXMLDaten) '(„C:\lexware\XMLExport\FakturaExport3.xml“)“, und wie oben erwähnt, liegt jetzt alles auf „C:\ProgramData\Lexware\faktura + auftrag\Formular\XMLExport“, allerdings ohne eine „FakturaExport3.xml“ im Datenpfad.

Das kann ich mir ehrlich gesagt nicht vorstellen: es ist ja ansonsten alles da: die Aufträge seit 2006, die Artikel, die Kunden; die Formulare sind ja auch da, nur ist der Export nach Word noch fehlerhaft, oder das Makro, oder was auch immer…

Wenn es jetzt nur ein einziges Formular wäre, würde ich ja noch sagen „Sch… der Hund drauf, mach’s neu!“, aber es sind im Laufe der Zeit 19 (!!!) unterschiedliche Rechnungsformulare geworden…

Wo habe ich das hier irgendwo gelesen? „Never change a running system!“

Ich hätte mit XP gut weiter arbeiten können, denn seit Win 7 klappt hier so einiges nicht mehr - weder die Umstiege von Windows 3.11 auf Windows 98, auf Windows 2000 oder auf Windows XP haben so viele Probleme bereitet, wie der Umstieg auf Windows 7 - ich weiß schon, warum ich da lange Zeit einen riesengroßen Bogen drum herum gemacht habe…

Hallo Achim,

ich zielte mit der Frage mehr darauf, ob denn die „normalen“ Formulare, also nix mit Export nach Word etc., funktionieren, Du also Aufträge mit den Standard-Formularversionen anzeigen und drucken kannst?

Die Pfade bei der Installation sollten damit nichts zu tun haben. Die Rücksicherung wird schon passend rückgesichert.

Ich lese bei Dir Installation, Installation, Installation, Rücksicherung. Ablauf sollte aber sein: Installation der Version aus der die Datensicherung stammt, Rücksicherung, Programm öffnen, alle vorhandenen Mandanten öffnen, schliessen, Installation nächste Version, Programm öffnen, alle vorhandenen Mandanten öffnen, schliessen… bis Du eben an der für Dich aktuellsten Version stehst.

Wenn Du die Version zuerst installierst, aus welche die Datensicherung stammt und dann rücksicherst, auch nicht?

So als Ansatz: mit welcher Wordversion wird denn auf dem neuen PC gearbeitet? Evtl. liegt es daran, dass die .dot doch etwas älter ist und diese nicht mehr mit der aktuelleren (?) Word-Version kompatibel ist?

Warum genau eigentlich umbenennen? Geht es denn nach kopieren und ohne umbenennen?

Bei Technik schliesse ich nix aus, zumindest nicht pauschal. :slight_smile: Wie geschrieben: ggf. hängt es an der Word-Version auf dem neuen PC?

Ok, Du nutzt 19 unterschiedliche .dot-Vorlagen? Die Direktformular in Lexware sind nicht ausreichend (was uns wieder zur ersten Frage zurückführt)?

Na, dass kann man so pauschal nicht sagen. Ex arbeiten ja x AnwenderInnen mit Lexware unter Win7 ohne diese Probleme. Die Kombi von „Altversion“ und OS Wechsel wirkt hier ggf. ein… Unter anderem ein Grund, warum ich es nicht unwichtig finde, regelmässig (mind. alle 2 Jahre) die Programmversion zu aktualisieren.

Fragen also:

  • Ist der Ablauf von Dir so durchgeführt worden wie oben von mir beschrieben? (dürfte aber nicht Ursache sein)
  • Sind es tatsächlich 19 .dot Vorlagen? Die „internen“ Formulare im Programm zum Direktdruck werden gar nicht genutzt bzw. funktionieren auch nicht?
  • Welcher Aufwand wäre es denn, die Vorlagen neu zu machen?

Da zu diesem Thema seit >2 Monaten keine Aktivität besteht und die Nachfrage(n) bisher auch unbeantwortet sind, gehe ich davon aus, der Sachverhalt hat sich geklärt und schliesse es daher.

Sollten doch noch Fragen offen sein oder Anmerkungen notwendig, bitte ein neues Thema eröffnen.

Danke.